24th May 2017

Our Software Dota 2 Update

A recent Dota 2 update has rendered our services inoperable. We are looking into the issue. Everyone's subscription has been extended by one day because of the delay.

Update 1

An update has been released to address the issues.

Update 2

It seems there are still a lot of crashing issues. Our developers are working on a fix.

Update 3

An update has been released to address the remaining issues.