7th June 2017

PayPal unavailable.

We are aware of some issues users are having when trying to make a payment via PayPal. We are currently investigating the issue.

Update 1

It seems as though this is an issue on PayPal's end. There have been a lot of reports of similar problems occurring on other websites. More information available here.

Update 2

Things seem to be operating normally now.