16th December 2025

Our Software Dota 2 Update

A recent Dota 2 update has rendered our software inoperable. We are currently investigating the issue.

Update 1

We've released our initial fix. A few things may still be broken, so if you notice anything in particular, let us know on the forums.

Update 2

It appears more things are broken than we thought. Currently looking into it.
Compensation will roll out once everything is stable.

Update 3

We've released a secondary fix for the crashing issues. If you're still experiencing constant crashing, please let us know on the forums.

Edit: Still investigating random crashes.