7th July 2017

Our Software Dota 2 Update

The latest Dota 2 update has rendered our client unusable. We are currently investigating the cause of the crashes.

Update 1

The fix for this update is taking us longer than anticipated. We have gone ahead and decided to use this opportunity to release a few updates we have been working on over this last month. Most of these changes are in response to user feedback we have received. Depending on how long it takes us to finish we will extend everybody's active subscription accordingly. Thank you for your patience, we will provide further updates as we progress.

Update 2

We have completed our fixes for the latest updates and are beginning work on finishing our planned updates.

Update 3

We have extended everyone's subscription by 1 day. Work on the updates should be completed soon.

Update 4

We are preparing to release the update now.

Update 5

The update has been released. Your client should automatically update. If it does not, please download it from the website. A changelog will be available in the forums.