15th March 2017

Our Software Dota 2 Update

Initial report

Dota 2 update has rendered the client inoperable. Currently being updated...

Update #1

The update is taking slightly longer than normal because we are finishing up some changes that we were working on prior to the Dota 2 update. We have extended all active subscriptions by one day, although we expect to have the update finished sooner than this.

Update #2

We have fixed the software for the latest Dota 2 update and are now just adding the final touches to the changes we were working on. Our release should be ready soon.

Update #3

We have launched our update that fixes the software for the latest Dota 2 update. Your client should automatically download the new update. More details will be available on the private forums soon.