22nd November 2017

Our Software Dota 2 Update

A recent Dota 2 update has rendered our software inoperable. We are currently looking into the issue.

Update 1

Along with fixing the client for the latest version of Dota 2, we'll also be releasing a new update for the client. The update may take a little while.

Update 2

We have released the fix to the crashing issues.