3rd April 2018

Distributor Servers Dota 2 Update

A recent Dota 2 update has rendered our software inoperable. We are currently looking into the issue.

Update 1

We've turned off distributor servers because the crash occurs when entering a match. We are still fixing the problems with the latest update. We've also extended everyone with an active subscription by one day because of the downtime.

Update 2

We've fixed nearly everything and have begun preparing the update. Everything should be ready soon.

Update 3

We've released an interim fix for the latest update. Everything should work as normal (64-bit only). Expect further updates soon.