13th June 2018

Our Software Dota 2 Update

A recent Dota 2 update has rendered our software inoperable. We are currently looking into the issue.

Update 1

There appears to be a lot of internal engine changes with this latest Dota 2 patch. We're still working on it, but currently have no ETA on when a fix will be released. As always, if this update ends up taking too long, we will reimburse lost subscription time.

Update 2

Our software has been updated to work with the latest Dota 2 update.