7th December 2018

Our Software Dota 2 Update

A recent Dota 2 update has rendered our software inoperable. We are currently investigating the issue. As always, if this update takes us too long to fix, we will extend everyone's subscription accordingly.

Update 1

We've released an initial fix for the 64-bit version of our software. Please read the change logs for more details.

Update 2

We've released the fix for the 32-bit version as well.