5th March 2019

Our Software Dota 2 Update - Mars

The latest Dota 2 update has rendered our software inoperable. We are looking into the issue.

Update 1

We have fixed 64-bit version of the client. Still working on 32-bit.

Update 2

The 32-bit version of the client has been fixed.