7th May 2019

Our Software Dota 2 Update

A recent Dota 2 update has rendered our software inoperable. We are currently looking into the issue.

Update 1

We've released an initial fix for the 64-bit version. A fix for the 32-bit version will come later.

Update 2

Both 64-bit and 32-bit have been fixed. If you experience any issues, let us know here: https://hake.me/forums/forums/help-and-support.16/