5th May 2017

Our Software Dota 2 Update

A recent Dota 2 update has rendered our client unusable. We are currently looking into fixing the issue.

Update 1

We have finished implementing a fix for the latest Dota 2 update. Before we release the fix we need to finish and test some updates that we were getting ready to release soon. We've gone ahead and extended everyone's subscription by one day to account for the time it may take us to complete and test these changes.

Update 2

We have finished testing our changes and are preparing the release. The update should be ready soon.

Update 3

The update has been released. A change log will be available on the forums soon.