7th June 2019

Our Software Dota 2 Update

A recent Dota 2 update has rendered our software inoperable. We are currently looking into the issue.

Update 1

We have released an update that fixes the 64-bit version. We're still working on the 32-bit version.

Update 2

We have fixed 32-bit. If you have any problems, please let us know on the forums. https://hake.me/forums/forums/help-and-support.16/