26th November 2019

Our Software Dota 2 Update

A recent update has rendered our software inoperable. We're investigating the issue.

Update 1

We have released an update for the latest version of Dota 2.

Update 2

We are still looking into some other crashes that are occurring

Update 3

We believe we have fixed the crashing issues. If you experience any bugs or have any issues, please make a thread in the Help & Support forum.