18th December 2019

Our Software Dota 2 Update

A recent Dota 2 update has rendered our software inoperable. We are currently investigating the issue.

Update 1

The fix is taking longer than expected, but it should still be finished by today. If for some reason we cannot release the fix by today, we will reimburse lost subscription time.

Update 2

We've released a fix for the latest update. Because it took us longer than normal we've extended all existing subscriptions by one day.