25th May 2020

Our Software Dota 2 Update

A major update for Dota 2 has caused our software to become inoperable. We are investigating the issue.

Update 1

We've released an update to address the latest changes. This update is for the GUI Beta version only at this time. An update for the legacy version will be released at a later date. Please check the changelog for more details.

Update 2

A fix has been released for the old version.

More crashes have been fixed, some features have been fixed. There may be some edge cases where something doesn't work properly. We are still working on those.